QuickStart

First ensure that the application is correctly installed.

IMPORTANT INFORMATION:

The first time that you run PCHi-Note, you will be prompted to open a database file to view and edit. It is very important to the successful operation of PCHi-Note that the correct file is opened. You should open the backed-up Hi-Note database file that is created by HotSync. This file is called hi-notedb.pdb and is located somewhere similar to:
       c:\palm\username\backup\hi-notedb.pdb,
where 'username' is similar to your Palm user name.

If you don't open this file with PCHi-Note, then the mechanism of transferring Hi-Note data between the PC and the Palm will not work correctly.

Also, it is wise to make regular backups of the hi-notedb.pdb file incase of a situation where this file becomes corrupted or lost in some manner. In my experience, it is not recommended to rely on tte HotSync mechanism to ensure that your Palm data is reliably backed-up and secure.


Starting PCHi-Note

Now run the application PCHiNote. PCHi-Note automatically opens the database that you previously had open. If this is the first time you have run this application then there will be no previously opened database (obviously), so you will be prompted to select a database to open. So continue by clicking the Browse button to open an existing database, or you may create a new Hi-Note® database by selecting a folder where you wish to store the new database, and then typing a name for it in the File name edit box.

Application Screen

You will then be presented with the main application window: as shown below.

All essential information is displayed on this screen.

You can navigate around the application by either keyboard or by mouse. All functionality is accessible by either means. With the keyboard, you can tab to the various fields, in the standard manner for Windows applications. Or you can use the shortcut keys (ie. Alt+R to toggle the ReadOnly status of a note). All other actions are available from the menus.

Database Navigation

see Tree Display Window

Okay. Now you are ready to navigate the database, and view and edit records. Use the Category Display list to select the required category. There are generally two types of users. Those that prefer to see all the records in the tree, and hence have the ALL category selected in the Category Display. The other type of user will generally only view one category at a time n order to maximise the use of the tree display window. Personal preference will dictate which you prefer.

Once you have selected the category, you can click on an record in the tree, or just tab to move the focus to the tree display. Now click on an item, or use the cursor keys to change the selected record. The other information areas of the application will be updated to display the information associated with the selected record.

Each record can contain either textual data or image data. This is indicated by a small graphical indicator to the left of the record title.

If a record has subrecords, there will be a + or - to the left of the graphical indicator and title. Clicking on it will expand or collapse the branch below it. You can also achieve this by using the Enter key to toggle the status.

Creating a New Record

Select the Tree Context Menu by right clicking in the Tree Display Window or open the Edit menu from the application menu bar. Create a new note by selecting from one of the 3 different types, either New Note, New Sub Note or New Super Note. A default title will be given to the new note, and you can immediately type the new title and text. When finished typing the new title, either click somewhere outside the title edit box or press Enter to finish editing.

See the New... commands on the Edit menu and the Tree Context Menu and Import Note and Import Picture on the Tools menu and the Copy/Paste commands on the Tree Context menu for ways to create or insert new notes and pictures.

Editing a Record

Once you have selected the record to edit, you are allowed to modify (almost) all data associated with the record.

Title
The record title may be edited in the Tree Display Window, or it can be edited in the Note Window
Note
The attached note may be edited using normal Windows editing techniques, unless it is readonly.
Picture
The attached picture may be edited by doubling clicking on the picture or by pressing the Insert key when the keyboard focus is in the Attached Picture Window, unless it is readonly.
Private Property
Toggle this check box to enable or disable the Private Status of the current record. Private records will not be displayed if the Hide Private Records is enabled.
ReadOnly Property
Toggle this check box to enable or disable the ReadOnly status of the current record. When checked, the attached note cannot be modified.
Item Category
Change the category of the current item by selecting a category name from the drop-down list. You can edit the categories by clicking the button Edit Categories button to add, rename or delete an existing category.

Saving the Database

Changes will only be permanently saved back to the database when you select one of the Save... options from the File menu.

Warning : If you exit without saving, any changes that were made since you last saved the database will be lost!

Okay. You have made it through the basics. There is more advanced functionality available which you will easily discover as you explore the application and tis help document.

Thankyou for taking the time the evaluate this application. I hope you enjoy using it, and that it may be of use to you.

I welcome all feedback regarding the things you like and dislike about PCHi-Note, so please feel free to e-mail me with your thoughts and suggestions. Thanks again.